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s Learning Objective
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Automatic left atrial (LA) scar detection in Slicer
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Incomplete Isolation

First PVAI - Posterior

Complete Isolation

Second PVAI - Posterior Second PVAI - Posterior

McGann et al. JACC,52(15): 1263-1272, 2008
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Current Workflow

Acquire Manually segment Manually
LGE-MRI LA wall segment scar
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Current Workflow

Raw Data Clustered Data

Manually Automatically
segment scar segment scar

Perry et al. SPIE, Feb. 2012
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s Required Materials

Slicer: Release 4.1
http://www.slicer.org/pages/Downloads/

Data: CARMA Left Atrial Scar

http://wiki.na-mic.org/Wiki/index.php/File: CARMA-LA-
Scar TutorialContestSummer2012.zip
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,
Additional Sample Data

32 patients

http:// www.insight-journal.org/midas/collection/view/197
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Pre-requisite Tutorial

P

Surgical Planning Laboratory
Brigham and Women'’s Hospital a teaching affiliate of
Boston, Massachusetts USA Harvard Medical School

Data Loading and 3D Visualization

Sonia Pujol, Ph.D., Harvard Medical School
Director of Training, National Alliance for Medical Image Computing

http://www.slicer.org/slicerWiki/index.php/Documentation/4.0/Training
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f’? Platforms

Developed Tested
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!E= 3DSlicer
w

» Help & Acknowledgement

o vorose Exensons 1) | it Etenins —
carma M Add data into the scene Parameter set: | Automatic Left Atrial Scar D
Alan Morris (CARMA), Danny Perry (CARMA), Josh Cates (CARMAY), Rob
MacLeod (CARMA), Eugene Kholmovski (CARMA) Choose Directory to Add| | Choose File(s) to Add | Show Options Status Idie
i v File A Description Options )
o™ ¥t TutoralCARMA-  Volume s vl Centered | | ignore Orientation v/ LabelMap ¥’ Single File R image o ‘
] S -mri s
Description ¥ ...r_Tutorial/CARMA- ‘ Volume s ‘ 1-mri Centered ___ Ignore Orientation || LabelMap ¥ Single File LAwalmask [ 1wal 3
The CARMA extension includes modules for the Utah Afib DBP ) " " =
CARMA | ...r_TutorialCARMA- Ivolume s ‘ 1-blood_pool Centered | | Ignore Orientation ¥/ LabelMap ¥/ Single File Blood Pool mask  1-blood_pool ol
Screenshots
Result [Resutt 2]
Created way 31, 2012
24m8
2 downloads
Tutorials
There are no tutorials for ths extension.
"L Reset | 7‘
User Comments @ Reset X cancel
Loain o reaister to add a comment =
1 o
* Restart requested X cose
Default Cancel Apply

Load the Load the Automatic scar
module dataset detection

National Alliance for Medical Image Computing

. © 2011, All Rights Reserved
http.//www.na-mic.org




.
Loading the Module

@& slicer File Edit [T Help B Y@ = ; = ¢ GO Frill:02PM Greg Q
600 Python Interactor %3 3D Slicer 4.1.0-2012-06-06
* i i —
I;j @ Modules: Extension Manager 34 — 0 @ © % ﬁ 7 $ - = ‘;b.
v Module Panel 85 = H
Toolbars > —
#) 3pslicer & Layout >
‘d Error Log #0

Select View>Extension

Welcome ,
e T T Manager in the menu bar

(or push 364)
\

>>>>>>

e If the Extension Manager

E— 1sn’t revealed, see the next

2 slides; otherwise, skip
them
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.
Loading the Module

& 9 ) = < (= 100%) Fri11:09PM Greg Q

P

| 3D Slicer 4.1.0-2012-06-06

= C NPO e 2 EIt-E w4+

icer
oo lodules: ‘t lelcome to Slicer
@®
“‘ Slicer ,

o load the Extension
Welcome
Manager, Select

[Sizciay Load DICOM Data [oasy Load Data
48 Customize Slicer O Download Sample Data E 1 it> 3 liC ati
» About pp

Settings in the menu bar

» Loading and Saving

(or push 362)

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

v Data Probe

[ N
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Loading the Module

Settings
General Enable extension manager: ¥
Modules -
Extensions server URL: http:/slicer.kitware.com/midas3

Cache

QtTesting Extensions installation path: JUser
\%}Eg\% rendering ;/ 0
' Under the Extension
menu, make sure
‘Enable extension
..
manager’ is checked

- /

\ﬁ/SIicer.app/Coments/ExtenSzons

gOpen Extension Manager...

L, Reset Restore Defaults | JOK H x Cancel‘
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.
Loading the Module

Manage Extensions (0)

Slicer Extensions
Categories
= All

= CARMA

= Examples
= Registration

= Segmentation

£\ Install Extensions

//Select CARMA 1n the\
sidebar and click the
extensions

= /

\:‘)Reslan X Close

National Alliance for Medical Image Computing
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' Loading the Module

ﬁ Manage Extensions (1) i\ Install Extensions

carma
Alan Morris (CARMA), Danny Perry (CARMA), Josh Cates (CARMA), Rob
MacLeod (CARMA), Eugene Kholmovski (CARMA)

>

Description

The CARMA extension includes modules for the Utah Afib DBP

Screenshots

-
Restart to install the

Created May 31, 2012

extension
\_

|1

Tutorials

There are no tutorials for this extension.

User Comments
Loain or reaister to add a comment

* Restart requested X Close iRestart
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.
Loading the Data

® 00

3D Slicer 4.1.0-2012-06-06

@ Modules: £\ Weicome to Slicer s = ) O Q @ D % Z Z t -~ fa 5o v

ex B

@ iDSlicer
Welcome

O Download Sample Data

[Gisy Load DICOM Data

&> Customize Slicer
» About
» The Main Window

» Loading and Saving

» Display

To load the data, select
Load Data from the
default ‘Welcome to

Slicer’ module

\_

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

¥ Data Probe

~
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.
Loading the Data

Add data into the scene

v

|Choose Directory to Add || Choose File(s) to Add |
& File

e
Select ‘Choose Directory
to Add’ in the pop-up

_menu

~

“ Reset

-~

Show Options

Description

National Alliance for Medical Image Computing
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.
Loading the Data

Add data into the scene

v

|Choose Directory to Add || Choose File(s) to Add |
& File

e
Select the directory

containing the CARMA-
( LA-Scar dataset

)

“ Reset

-~

Show Options

Description
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Loading the Data

Add data into the scene

Choose Directory to Add || Choose File(s) to Add | |:> Show Options
v File ~ Description

v /Users/Greg/Desktop/Scar_Tutorial/lCARMA-LA-Scar_TutorialContestSummer2012 2/1/1-wall.nrrd ‘Volume = ‘
v /Users/Greg/Desktop/Scar_Tutoria/lCARMA-LA-Scar_TutorialContestSummer2012 2/1/1-mri.nrrd ‘Volume - ‘
v /Users/Greg/Desktop/Scar_Tutoria/lCARMA-LA-Scar_TutorialContestSummer2012 2/1/1-blood_pool.nrrd ‘Volume — ‘

- N

Make sure all 3 volumes
are selected and click
‘Show Options’

N J
“ Reset iOK x Cancel ‘

National Alliance for Medical Image Computing
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Loading the Data

Add data into the scene

|Choose Directory to Add || Choose File(s) to Add | v Show Options
v File ~ Description Options

< ...r TutoriallCARMA- | Volume A | 1-wall Centered lgnore v LabelMap ¥ Single File
v ...r_Tutorial/CARMA- | Volume 2 | 1-mri Centered lgnore Orientation LabelMap + Single File
< ..t TutoriallCARMA- :VVolume :7 1-blood_pool Centered lgnoreq:> v LabelMap ¥ Single File

Designate the wall and blood A

pool volumes as label masks,

then push ‘OK’
- /

“ Reset | ;OK x Cancel
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' Adjustin

d the Viewer

68 00

3D Slicer 4.1.0-2012-06-06

Modules: £\ Welcome to Slicer -9
“‘ 3DSlicer
[Giecay Load DICOM Data [acy Load Data

DY O ed 2

1

.

@ ®

Expose the viewer

48: Customize Slicer O Download Sample Data

» About

options, and select the
[ | button to link the viewers

» The Main Window

¥ Loading and Saving

MRML:The Medical Reality Markup Language (MRML) scene file is an XML-based text file
that references all data loaded into Slicer, and records its display and processing
parameterization. Loading a MRML scene file will also load its referenced data and display it

in the manner it was saved.
Loading Scenes & Data

File->Load Scene:
This load command selected from Slicer's File Menu will close the current
scene, pop up a File Browser, and load data from the MRML scene file you
select.

File->Import Scene:
This load command selected from Slicer's File Menu will pop up a File
Browser, and add all data referenced in the MRML scene file you select into
the current scene.

File->Add Volume:
This command allows the loading of individual volumes or use of Slicer's
DICOM browser.

File->Download Sample Data:

This command provides an option to download a variety of anonymized
datasets for learning and testing in Slicer. Because the datasets are hosted
in a remote repository, a network connection is required to access them.

"

LT

» & A& v|Axial

¥ Data Probe

~
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' Adjusting the Viewer

3D Slicer 4.1.0-2012-06-06

800
Lo &

o

@ Modules:

S
I
!

@ 3DSlicer

£\ Weicome to Slicer

Welcome

[Gisciay Load DICOM Data

48 Customize Slicer

) Download Sample Data

sy Load Data

» About

» The Main Window

v Loading and Saving

MRML:The Medical Reality Markup Language (MRML) scene file is an XML-based text file
that references all data loaded into Slicer, and records its display and processing
parameterization. Loading a MRML scene file will also load its referenced data and display it

in the manner it was saved.

PO @« d

Conventional Widescreen
Conventional Quantitative
[ Four-up
[ Four-Up Quantitative
[ pualap
B Triple 3D

=T ooy
I |D Red slice only

Loading St

#| Click the

=

2l 1con and
select ‘Red slice only’
| from the drop-down menu

v Data Probe

@

T Temow-sTee oy
[ Green slice only
Tabbed 3D

[ Tabbed slice

= compare

[T compare Widescreen
B8 compare Grid

[ Three over three

[ Four over four

[ Two over Two
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' Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

6 00
kS

E

0 ag) Modules: £\ Welcome to Slicer

Ao R,

74|
9 3DSlicer tﬁ

7

Welcol2

A

- %
sy Load DICOM Data | gy
48 Customize Slicer

@

» About

All Modules

Annotations
DICOM

Data

Editor

Models
OpenlGTLinkIF
Scene Views
Transforms
View Controllers

@ Volume Rendering

Volumes

£\ Welcome to Slicer

L CARMA [ Automatic Left Atral Scar

» The Main Window

Wizards
I
v Loading and Saving | Registration
MRML:;rhe Medical Reality Markup L Segmentation
that references all data loaded in )
parameterization. Loadinga MRMLs¢ ~ Quantification
in the manner it was saved. Diffusion
Loading Scenes & Data
IGT
Filtering
p | File>Load Scene: Surface Models
This load commar_gd sBe Converters
scene, pop up a File
select. E”‘?‘?WDV
File->Import Scene: Utilities
This load command § Developer Tools
Browser, and add all di L
the current scene. egacy
Testing

File->Add Volume:
This command allows
DICOM browser.

Work in Progress

NP e« 2O t-E
R

Under the modules menu,
select CARMA>Automatic
Left Atrial Scar

TET

Jle Data

C Inhomogeneity Correction

based text file
, processing

1 and display it
»

» e the current
, icene file you

» Dp up a File
, bu selectinto

se of Slicer's
»

File->Download Sample Data:

v Data Probe

@

This command provides an option to download a variety of anonymized
datasets for learning and testing in Slicer. Because the datasets are hosted
in a remote repository, a network connection is required to access them.
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Automatic Scar Detection

=

Lo Modules: ‘| Automatic Left Atrial Scar > _v O' RN @ QO & E Z. D. t~ O] .;@v v

o

B 3psiicer

4

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

a

Parameter set: | Select a CommandLineModule 4
Status Completed
PIIIIIIIIIIIIIIIIIIIIIIIID
v 10
MRI image Select a Volume s
LA wall mask Select a Volume :
Blood Pool mask | Select a Volume s
Result Select a Volume s

Default Cancel Apply

¥ Data Probe

~
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/
Automatic Scar Detection

Input volumes
Output volume

@ 3DSlicer

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar

Status Idie
v 10

MRI image 1-mri

LA wall mask 1-wall

Blood Pool mask [ 1-blood_pool

Result Result

Default Cancel

O OO0

Apply

4= Parameter Sets

National Alliance for Medical Image Computing
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/
Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

D

8 0 O
ES

@ Modules: “- | Automatic Left Atrial Scar

I Q>N PO @@ 2 (Mt |8 w fl+-

@®

‘h‘ 3DSlicer
» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Select a CommandLineModule

PIIIIIII I I I I I I I IIIIII, Under the MRI Image

v 10

gl ficld, select the MRI

Blood Pool mask

_“ | image stack (1-mr1)

Default

v Data Probe

-
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/
Automatic Scar Detection

e (8] 3D Slicer 4.1.0-2012-06-06
Ba o Sa oo nvomatctetarascar 2™ Q QN P O @ @ 2 |EIt B M R4~
@x ER 1S: 42.50
r‘\ 3DSlicer
4

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar

Blood Pool mask| 1blood_pool

ametl ficld, select the label mask

Delete current Volume

Default Cancel Apply
v Data Probe

-
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Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

@ Modules: | Automatic Left Atrial Scar = QO O @ O @ L 7 ﬂ t~ o o v

@ A

_S:42.50

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar

Under the Blood Pool
_ Mask field, select the
Sy blood pool label mask (1-

blood pool)

Default Cancel Apply

v Data Probe

-
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< e Dot
Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

e 00
2,

@ Modules: Automatic Left Atrial Scar

@ 3DSlicer

» Help & Acknowledgement

¥ Automatic Left Atrial Scar
Parameter set: | Automatic Left Atrial Scar
Status

¥ o

MRI image 1-mri

LA wall mask 1-wall

Blood Pool mask | 1-blood_pool

Result 1-wall
1-blood_pool

Rename current Volume

(¢

ex 8

Idie

Create and rename new Volume

Delete current Volume

Default

¥ Data Probe

~

Apply

= QOINPO «d -« Olt-8 |+~

Under the Result field,
select ‘Create New

Volume,” which will be
named Result

_ S:42.50
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' Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

D

(3] (8]
£

Modules: ‘-, | Automatic Left Atrial Scar s ™= O RN @ Q % E A D. t - e o v

@ 3DSlicer

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar 4
Status Idie
v 10
MRIimage 1-mri A
LA wall mask 1-wall =
Blood Pool mask | 1-blood_pool A
Result Result i

- o Rl [ astly, apply the settings

¥ Data Probe

~
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Automatic Scar Detection

Modules: Automatic Left Atrial Scar = Q OINMY © @@ @ ﬂ t~ o S v

rb\ 3DSlicer

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar v

Status Running

(— Wait bar indicates the

v 10 . )
MRIimage [1.m : process 1 running
LA wall mask 1-wall a
Blood Pool mask | 1-blood_pool -
Result Result ]

Default Cancel Apply

¥ Data Probe

[ W
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Automatic Scar Detection

dm Q0 OINPO «d 2 M t-E Wl

Modules: ‘-, | Automatic Left Atrial Scar s
e BN

@

» Help & Acknowledgement

avg
Slicer

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar
Completed

Status
100%

v 10
MRIimage 1-mri
LA wall mask 1-wall

Blood Pool mask | 1-blood_pool

Result Result

a .
Viewer automatically

updates to show the
_resulting label mask

Cancel Apply

Default

¥ Data Probe

L
F
B
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% 3DSlicer

Jpwwwislicerorg for d

Student can use the module to automatically
detect LA scar in Slicer 4.1
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