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s Learning Objective

7% 30 Siicer 4.1.0-20124
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Automatic left atrial (LA) scar detection in Slicer
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Incomplete Isolation

Second PVAI - Posterior Second PVAI - Posterior

McGann et al. JACC,52(15): 1263-1272, 2008
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Current Workflow

Acquire Manually segment Manually
LGE-MRI LA wall segment scar
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Current Workflow

Raw Data Clustered Data

Manually Automatically
segment scar segment scar

Perry et al. SPIE, Feb. 2012
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s Required Materials

Slicer: Release 4.1
http://www.slicer.org/pages/Downloads/

Data: CARMA Left Atrial Scar

http://wiki.na-mic.org/Wiki/index.php/File: CARMA-LA-
Scar TutorialContestSummer2012.zip
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,
Additional Sample Data

32 patients

http:// www.insight-journal.org/midas/collection/view/197
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Pre-requisite Tutorial

P

Surgical Planning Laboratory
Brigham and Women'’s Hospital a teaching affiliate of
Boston, Massachusetts USA Harvard Medical School

Data Loading and 3D Visualization

Sonia Pujol, Ph.D., Harvard Medical School
Director of Training, National Alliance for Medical Image Computing

http://www.slicer.org/slicerWiki/index.php/Documentation/4.0/Training

National Alliance for Medical Image Computing 2011, All Rights Reserved
http://www.na-mic.org ,



f’? Platforms

Developed Tested

54
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f? Overview

®
f !U= 3DSlicer
4
» Help & Acknowledgement
i Manage Extensions (1) | gy Instal Extensons : :
- — v Automatic Left Atrial Scar
carma i Add data into the scene Parameter set: | Automatic Left Atrial Scar D
Alan Morris (CARMA), Danny Perry (CARMA), Josh Cates (CARMA), Rob
MacLeod (CARMA), Eugene Kholmovski (CARMA) Choose Directory to Add| | Choose File(s) to Add| | Show Options Status Idie
> v File -~ Description Options ~ 10
ST < ...t TutoriallCARMA- [vomme s ‘ 1-wall Centered | | Ignore Orientation | LabelMap ¥ Single File - -
17 MRI image [1-mri $)
ot i - < [1mi Centered nore Orientation _ LabelMap ¥ Single File
Description ¥ ...r_Tutorial/CARMA- ‘anuma s ‘ 1-mri g ing LAwalmask (1l |
The CARMA extension includes modules for the Utah Afib DBP ———— _
CARMA ¥ ...r_Tutorial/CARMA- ‘Volume 5 ‘ 1-blood_pool Centered | | Ignore Orientation ¢! LabelMap ' Single File Blood Pool mask 1-blo0d_pool s
Screenshots
Result [Resutt 2]
Created May 31, 2012
2.4m8
2 downloads
Tutorials
There are no tutorials for this extension.
T —_—
User Comments b pose X corel |
Loain or raaister t add a comment
I
* Restart requested X Close
Default Cancel Apply

Load the

module

Load the

dataset

Automatic scar

detection
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.
Loading the Module

@& slicer File Edit [T Help B Y@ = ; = ¢ GO Frill:02PM Greg Q
600 Python Interactor %3 3D Slicer 4.1.0-2012-06-06
* i i —
I;j @ Modules: Extension Manager 34 — 0 @ © % ﬁ 7 $ - = ‘;b.
v Module Panel 85 = H
Toolbars > —
#) 3pslicer & Layout >
‘d Error Log #0

Select View>Extension

Welcome ,
e T T Manager in the menu bar

(or push 364)
\

>>>>>>

e If the Extension Manager

E— 1sn’t revealed, see the next

2 slides; otherwise, skip
them
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.
Loading the Module

& 9 ) = < (= 100%) Fri11:09PM Greg Q

F

| 3D Slicer 4.1.0-2012-06-06

= G NPO e 2 EIt-E w4+

icer
oo lodules: ‘t lelcome to Slicer
@®
“‘ Slicer ,

o load the Extension
Welcome
Manager, Select

[Sizciay Load DICOM Data [oasy Load Data
48 Customize Slicer O Download Sample Data E 1 it> 3 liC ati
» About pp

Settings in the menu bar

» Loading and Saving

(or push 362)

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

v Data Probe

[ N
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Loading the Module

Settings
General Enable extension manager: ¥
Modules -
Extensions server URL: http://slicer.kitware.com/midas3

Cache

QtTesting Extensions installation path: JUser
ng\?a rendering ;/ 0
' Under the Extension
menu, make sure
‘Enable extension
..
manager’ is checked

- /

\ﬁ/SIicer.app/Coments/Extens:ons

gOpen Extension Manager...

L, Reset Restore Defaults | JOK H x Cancel‘
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.
Loading the Module

Manage Extensions (0)

Slicer Extensions
Categories
= All

= CARMA

= Examples
= Registration

= Segmentation

éx Install Extensions

//Select CARMA 1n the\
sidebar and click the
extensions

= /

\;)Restan X Close

National Alliance for Medical Image Computing
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' Loading the Module

i Manage Extensions (1) i\ Install Extensions

carma
Alan Morris (CARMA), Danny Perry (CARMA), Josh Cates (CARMA), Rob
MacLeod (CARMA), Eugene Kholmovski (CARMA)

>

Description

The CARMA extension includes modules for the Utah Afib DBP

Screenshots

-
Restart to install the

Created May 31, 2012

extension
\_

|1

Tutorials

There are no tutorials for this extension.

User Comments
Loain or reaister to add a comment

* Restart requested X Close aRestart
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.
Loading the Data

® 00

3D Slicer 4.1.0-2012-06-06

@ Modules: £ Weicome to Slicer s = ) O Q @ D % Z Z. t -~ fa So v

ex B

@ iDSlicer
Welcome

O Download Sample Data

[Gisy Load DICOM Data

&> Customize Slicer
» About
» The Main Window

» Loading and Saving

» Display

To load the data, select
Load Data from the
default ‘Welcome to

Slicer’ module

\_

» Mouse & Keyboard

» Documentation & Tutorials

» Acknowledgment

¥ Data Probe

~
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.
Loading the Data

Add data into the scene

v

'Choose Directory to Add || Choose File(s) to Add |
& File

-
Select ‘Choose Directory
to Add’ in the pop-up

_menu

~

“ Reset

-~

Show Options

Description
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.
Loading the Data

Add data into the scene

v

'Choose Directory to Add || Choose File(s) to Add |
& File

-
Select the directory

containing the CARMA-
( LA-Scar dataset

)

“ Reset

-~

Show Options

Description

National Alliance for Medical Image Computing
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Loading the Data

Add data into the scene

Choose Directory to Add || Choose File(s) to Add | |:> Show Options
v File ~ Description

v /Users/Greg/Desktop/Scar_Tutorial/lCARMA-LA-Scar_TutorialContestSummer2012 2/1/1-wall.nrrd ‘Volume = ‘
v /Users/Greg/Desktop/Scar_Tutoria/lCARMA-LA-Scar_TutorialContestSummer2012 2/1/1-mri.nrrd ‘Volume - ‘
v /Users/Greg/Desktop/Scar_Tutoria/lCARMA-LA-Scar_TutorialContestSummer2012 2/1/1-blood_pool.nrrd ‘Volume — ‘

- N

Make sure all 3 volumes
are selected and click
‘Show Options’

N J
“ Reset iOK x Cancel ‘

National Alliance for Medical Image Computing
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Loading the Data

Add data into the scene

|Choose Directory to Add || Choose File(s) to Add | v Show Options
v File ~ Description Options

< ...r TutoriallCARMA- | Volume A | 1-wall Centered lgnore v LabelMap ¥ Single File
v ...r_Tutorial/lCARMA- | Volume a | 1-mri Centered lgnore Orientation LabelMap + Single File
< ..t TutorialCARMA- ‘VVolume :7 1-blood_pool Centered lgnoreq:> ¥/ LabelMap ¥ Single File

Designate the wall and blood A

pool volumes as label masks,

then push ‘OK’
- /

“ Reset | iOK | x Cancel |
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' Adjustin

d the Viewer

68 0 O

3D Slicer 4.1.0-2012-06-06

Modules: £\ Welcome to Slicer = _. O

@ 3DSlicer
Welcome

QMO &«d ~

e El

Expose the viewer

[Giecay Load DICOM Data [acy Load Data
48; Customize Slicer O Download Sample Data
» About

options, and select the | @,
[ | button to link the viewers

» The Main Window

¥ Loading and Saving

MRML:The Medical Reality Markup Language (MRML) scene file is an XML-based text file
that references all data loaded into Slicer, and records its display and processing
parameterization. Loading a MRML scene file will also load its referenced data and display it

in the manner it was saved.
Loading Scenes & Data

rﬁ! File->Load Scene:

This load command selected from Slicer's File Menu will close the current
scene, pop up a File Browser, and load data from the MRML scene file you
select.

File->Import Scene:
This load command selected from Slicer's File Menu will pop up a File
Browser, and add all data referenced in the MRML scene file you select into
the current scene.

File->Add Volume:
This command allows the loading of individual volumes or use of Slicer's
DICOM browser.

File->Download Sample Data:

This command provides an option to download a variety of anonymized
datasets for learning and testing in Slicer. Because the datasets are hosted
in a remote repository, a network connection is required to access them.

TR

» & 4x v|Axal

¥ Data Probe

-
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http://www.na-mic.org



' Adjusting the Viewer

3D Slicer 4.1.0-2012-06-06

800
& &

o

@ Modules:

S
S
!

@ 3DSlicer

£\ Weicome to Slicer

Welcome

[Giscay Load DICOM Data

48 Customize Slicer

) Download Sample Data

[oasy Load Data

» About

» The Main Window

v Loading and Saving

MRML:The Medical Reality Markup Language (MRML) scene file is an XML-based text file
that references all data loaded into Slicer, and records its display and processing
parameterization. Loading a MRML scene file will also load its referenced data and display it

in the manner it was saved.

PO @« d

Conventional Widescreen
Conventional Quantitative
[ Four-up
[ Four-Up Quantitative
[ Dualap
B Triple 3D

=T oo oy
I |D Red slice only

Loading St

#| Click the

=

2l 1con and
select ‘Red slice only’
| from the drop-down menu

v Data Probe

@wmr

T Temow-sTee oy
[ Green slice only
Tabbed 3D

[E Tabbed siice

= compare

[T compare Widescreen
B compare Grid

[ Three over three

[ Four over four

B Two over Two
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' Automatic Scar Detection

8 O O 3D Slicer 4.1.0-2012-06-06
Eeg | Modules: £\ Welcome to Slicer : A @ O @ L 7 ﬂ t~ Y
All Modules , R

[Z] Annotations

E 3DSlicer "Qg:aOM
/. Editor -

Welcole ... Under the modules menu,

Fa Scene Views

- | 4 Transforms
[oicoy Load DICOM Data | pm view Controliers
1@ Volume Rendering
1§) Volumes
£\ Welcome to Slicer

4% Customize Slicer

» About

» The Main Window
in Wizards

Ir
| Registration
MRML:The Medical Reality Markup L Segmentation
that references all data loaded in Q ficati
parameterization. Loading a MRML s¢ uantification
in the manner it was saved. Diffusion
Loading Scenes & Data GT

Filtering

5 | File>Load Scene: Surface Models
This load commar_pd s Converters
scene, pop up a File
saioct. TP P Endoscopy
File->Import Scene: Utiities
This load command §  Developer Tools
Browser, and add all di Legac
the current scene. gacy
File->Add Volume: Testing
This command allows,
DICOM browser.

v Loading and Saving

Work in Progress

L cARMA [ Automatic Left Atral Scar

TET

select CARMA>Automatic
Left Atrial Scar

e Data

C Inhomogeneity Correction

based text file
, 1d_processing

dand display it
>

» e the current
, icene file you

» Dp up a File
, bu selectinto

se of Slicer's
»

File->Download Sample Data:

v Data Probe

@mr

This command provides an option to download a variety of anonymized
datasets for learning and testing in Slicer. Because the datasets are hosted
in a remote repository, a network connection is required to access them.
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Automatic Scar Detection

=

Lo Modules: ‘| Automatic Left Atrial Scar > _v O' RN @ QO & E Z. D. t~ O] .;@v v

o

B 3psiicer

4

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

a

Parameter set: | Select a CommandLineModule 4
Status Completed
PIIIIIIIIIIIIIIIIIIIIIIIID
v 10
MRI image Select a Volume s
LA wall mask Select a Volume :
Blood Pool mask | Select a Volume 4
Result Select a Volume s

Default Cancel Apply

¥ Data Probe

~
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/
Automatic Scar Detection

Input volumes
Output volume

@ 3DSlicer

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar

Status Idie
v 10

MRI image 1-mri

LA wall mask 1-wall

Blood Pool mask | 1-blood_pool

Result Result

Default Cancel

OO0 o

Apply

4= Parameter Sets

National Alliance for Medical Image Computing
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/
Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

D

8 0 O
ES

@ Modules: “- | Automatic Left Atrial Scar

I Q>N PO @@ 2 (M|t |8 w fl+-

@®

“‘ 3DSlicer
» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Select a CommandLineModule

PIIII I I I T I I T T IIFTITIIZZ, Under the MRI Image

v o

o gl ficld, select the MRI

Blood Pool mask

| e e image stack (1-mri)

Default Cance Apply

v Data Probe

-
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Automatic Scar Detection

® 0 0 3D Slicer 4.1.0-2012-06-06
Ba B B3 Mo Automatic Left Atrial S = QO INPO e«ad 2 O t-E W R v
ex ER 1S:42.50
r‘\ 3DS|
4

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar

Blood Pool mask| 1"blood_pool

amatl ficld, select the label mask

Delete current Volume

Default Cancel Apply
v Data Probe

-
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Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

@ Modules: | Automatic Left Atrial Scar = QO O @ O @ 4L 7 ﬂ t~ o v

@ A

_S:42.50

©

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar

Under the Blood Pool
= Mask field, select the
Sy blood pool label mask (1-

blood pool)

Default Cancel Apply

v Data Probe

-
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< e Dot
Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

e 00
2,

@ Modules: Automatic Left Atrial Scar

@ 3DSlicer

» Help & Acknowledgement

¥ Automatic Left Atrial Scar
Parameter set: | Automatic Left Atrial Scar
Status

¥ o

MRI image 1-mri

LA wall mask 1-wall

Blood Pool mask | 1-blood_pool

Result 1-wall
1-blood_pool

Rename current Volume

(¢

ex 8

Idie

Create and rename new Volume

Delete current Volume

Default

¥ Data Probe

~

Apply

= QOINPO «d -« Olt-8 |+~

Under the Result field,
select ‘Create New

Volume,” which will be
named Result

_ S:42.50
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' Automatic Scar Detection

3D Slicer 4.1.0-2012-06-06

D

(3] (8]
£

Modules: ‘-, | Automatic Left Atrial Scar s ™= O RN @ Q % E 7 D. t - e o v

@ 3DSlicer

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar 4
Status Idie
v 10
MRIimage 1-mri B
LA wall mask 1-wall =
Blood Pool mask [ 1-blood_pool 4
Result Result i

- Rl [ astly, apply the settings

¥ Data Probe

~
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Automatic Scar Detection

Modules: Automatic Left Atrial Scar = Q OINMY © @ @ u t~ o S v

‘b‘ 3DSlicer

» Help & Acknowledgement

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar v

Status Running

(— Wait bar indicates the

v 10 . )
MRIimage [1.m : process 1 running
LA wall mask 1-wall s
Blood Pool mask | 1-blood_pool s
Result Result s

Default Cancel Apply

¥ Data Probe

—
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Automatic Scar Detection

dm QO INPO «d 2 M t-E el

Modules: ‘-, | Automatic Left Atrial Scar s
e BN

@

» Help & Acknowledgement

avg
Slicer

¥ Automatic Left Atrial Scar

Parameter set: | Automatic Left Atrial Scar
Completed

Status
100%

v 10
MRIimage 1-mri
LA wall mask 1-wall

Blood Pool mask | 1-blood_pool

Result Result

a .
Viewer automatically

updates to show the
_resulting label mask

Cancel Apply

Default

¥ Data Probe

L
F
B

National Alliance for Medical Image Computing
http://www.na-mic.org



% 3DSlicer

Jpwwwislicerorg for d

Student can use the module to automatically
detect LA scar in Slicer 4.1
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