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• An end-user application for image 
analysis and visualization"

• An open-source environment for 
software development "

• A software platform that is both easy 
to use for clinical researchers and 
easy to extend for programmers"
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"
"
Disclaimer!
It is the responsibility of the user of 3DSlicer to comply with both the 
terms of the license and with the applicable laws, regulations and 
rules.  Slicer is a tool for research, and is not FDA approved."

3D Slicer version 3 is 
a multi-platform 

software running on 
Windows, Linux, and 

Mac OSX."

www.slicer.org 
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•  This workshop uses the newest 
release of 3D Slicer (version 
3.6.2). "

•  Visit the Slicer download page 
for Slicer 3.6 stable release, or for 
Slicer nightly builds."

www.slicer.org 
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•  Getting Started: Slicer3 Minute Tutorial"

•  Quantitative Measurement of Volumetric Change: 
ChangeTracker Tutorial "

•  Quantitative Measurements for Functional Imaging: 
PETCTFusion Tutorial!

All Tutorial Datasets are located in    C:\slicer_data !

Tutorial Overview 
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Tuning up… 

Setting Font Size!

"
In Slicerʼs main menu, select"
View->Application Settings!
!
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Tuning up… 

Setting Font Size!

This raises Slicerʼs 
Application Settings 
Interface!
"
In the left panel, select"
Font Settings!
!
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Tuning up… 

Setting Font Size!

This displays Slicerʼs Font 
Family and Font Size 
options!

"
Choose among options 
until you find a font-size 
that works well for you.!
!

Slicer will remember these settings next 
time you start the application."
"
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This tutorial is a short  introduction 
to the advanced 3D visualization 
capabilities of the Slicer3 software 
for medical image analysis."
"
It is designed to quickly build a 
basic level of comfort with the 
Slicer software. "

Slicer3 Minute Tutorial 

Part I: Slicer3 Minute Tutorial!

Sonia Pujol, PhD"
Wendy Plesniak, PhD"
"
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http://www.spl.harvard.edu/publications/item/view/1265 !

Slicer3 Minute Tutorial 

The Slicer3Minute dataset is composed of"
An MR scan of the brain and 3D surface"
Reconstructions of anatomical structures."
"
The data are part of the SPL-PNL Brain Atlas"
Developed by Talos et al. The atlas is available at:"
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Windows users:!
"
Double-Click the Shortcut to 
Slicer3.exe on the Desktop "
  "
or Select "
"

Slicer3 Minute Tutorial:  Launch the Application 

Start ->All Programs ->Slicer3 3.6.2010-10-22->Slicer !
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The Graphical User 
Interface (GUI) of Slicer3 
integrates five 
components: "
"
•  the Menu Toolbar"
•  the Module GUI Panel"
•  the 3D Viewer"
•  the Slice Viewer"
•  the Slice and 3D View 
Controller" Slice Viewers!

3D Viewer!Module 
GUI Panel!

Slice and 3D View 
Controller!

Menu & Toolbar!

Slicer3 Minute Tutorial:   Navigating the Application GUI 
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The SlicerWelcome 
module is the module 
displayed by default. "
"
"
"
This module gives an 
overview of the GUI of 
Slicer3, and data loading & 
saving functionalities. "

Slicer3 Minute Tutorial:   Welcome Module 
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Expand or shrink the 
GUI panel with the 
arrows at the frame top, 
or by clicking and 
dragging the vertical 
separator"

Expand or collapse 
any sub-panel by 
clicking on its grey title 
bar."

Slicer3 Minute Tutorial:   GUI Basics 
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Browse to the location of the 
Slicer_data directory."
"
Select that directory and select 
the Add To Favorites"
icon!
"
This will make the directory 
easier to find later..."

Select File-> Load Scene 
from the File menu"

Slicer3 Minute Tutorial:   Load A Scene!
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Browse to the location of the 
Slicer3MinuteDataset 
directory."
"
Select the scene file  
slicer3minute.mrml!
"
Click on Open to load the 
scene"

Slicer3 Minute Tutorial:   Load A Scene!
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When the scene is finished loading, 
Slicer displays:"
"
• a 3D model of the head in the 3D 
Viewer, and "
• anatomical MR slices of the brain in 
the 2D Slice Viewers."

3D Viewer !

2D Slice Viewers!

Slicer3 Minute Tutorial:   Viewing the Scene!
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Note: !
We have pre-adjusted the window and level 
settings for these volumes so that they are 
appropriate for display on most laptops. "
"
If display is not satisfactory on your machine 
or projector, the Volumes Module may be 
used to refine these settings. !
!

Slicer3 Minute Tutorial:   Viewing the Scene!
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Left click and hold the 
Modules menubutton. !
"
Select All Modules to 
display the many modules 
available for image 
processing, analysis and 3D 
visualization."

Slicer3 Minute Tutorial:   Exploring Slicer’s functionality!
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To access the Models 
module, browse 
through the list of 
modules..."
"
...or click on the 
models icon              
in the toolbar"

Slicer3 Minute Tutorial:   Exploring Slicer’s functionality!
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Slicer displays the GUI of the  Models 
module."

Slicer3 Minute Tutorial:   Switching to the Models Module!



-- CTSA at RSNA 2010 

Position the mouse in 
the 3D Viewer."
"
Hold down the left 
mouse button and 
drag to rotate the 
model."
"

Slicer3 Minute Tutorial:   Basic 3D Interaction!

Left-click & drag 
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Click on the 
Slice Visibility          

icon "
"

to display the 
Axial Slice in the 

3D Viewer "

Slicer3 Minute Tutorial:   Viewing Slices in the 3D Viewer!
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Slicer adds a view of the 
Axial slice in the 3D View."

Slicer3 Minute Tutorial:   3D Visualization!
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Select the Skin model."
"
Change the opacity of the 
model from            1.0 to 
0.0."

Slicer3 Minute Tutorial:   3D Visualization!
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The model of the skull bone and 
eyeballs become visible through the 

model of the skin in the 3D viewer."
"
"

(skin model opacity = 0.5)!

Slicer3 Minute Tutorial:   3D Visualization!
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The model of the skin becomes 
invisible in the 3D viewer."

"
(skin model opacity = 0.0)!
(skull model opacity = 1.0)!

Slicer3 Minute Tutorial:   3D Visualization!
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Slicer3 Minute Tutorial:   3D Visualization!

Click on the 
Slice Visibility                         
icon in the 
Green Slice 
Viewer"
"
to display the 
Coronal Slice in 
the 3D Viewer."
"
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Slicer3 Minute Tutorial:   3D Visualization!

Select the 3D 
model 
skull_bone.vtk 
in the Model 
Hierarchy and 
turn on the 
Clipping 
option. !
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Slicer3 Minute Tutorial:   3D Visualization!

Browse through the 
coronal slices to 
expose the 3D 
model of the white 
matter, and the left 
and right optic 
nerves. "
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"
Select the 3D model 
“skull_bone” in the 
Model Hierarchy, and 
turn off its Visibility!
"

Slicer3 Minute Tutorial:   3D Visualization!
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"
Scroll the Coronal Slices to display the 

hemispheric white matter model in the 
context of the image data in the 3D Viewer."

"

Slicer3 Minute Tutorial:   3D Visualization!
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"
Select the hemispheric white 

matter model called"
hemispheric_white_matter.vtk !

"
Turn off its visibility."

"

Slicer3 Minute Tutorial:   3D Visualization!
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Slicer displays the optic nerve, 
optic chiasm and optic tracts 
overlaid on the MR images of the 
brain."

Slicer3 Minute Tutorial:   3D Visualization!
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Windows/Linux users: Position the 
mouse in the 3D Viewer, hold down the 

right mouse button and move the 
mouse down to zoom in."

Mac users: Position the mouse in the 3D 
Viewer, hold down the apple button and 
the mouse button and move the mouse 

down to zoom in"
(or use two fingers on the touch pad)."

Slicer3 Minute Tutorial:   3D Visualization: Zoom the view!

To Zoom: 
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Slicer3 displays a closer 
view of 3D anatomical 

structures overlaid on 2D 
MR slices"

Slicer3 Minute Tutorial:   3D Visualization!
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This tutorial has demonstrated:"
"
•  Basic description of the Slicer3 Application Interface"
•  How to load a scene containing volumes and models"
•  How to visualize these different datasets together"
"

Next, we will use these building blocks to perform 
image analysis and visualize quantitative results."
"

Slicer3 Minute Tutorial:   Summary!
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"
Clear the previous scene."
"
Select File->Close Scene!

"
This removes any datasets 

previously  loaded into Slicer."
 "

Close the existing scene and all its data!
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The module described in this tutorial was tested on Axial 3D 
SPGR T1 post Gadolinium scans (Voxel dimension: 0.94mm x 
0.94mm x 1.20mm, FOV: 240mm, Matrix: 256 x 256)"

Part II: Analyzing Small 
Volumetric Changes using the 
ChangeTracker Module!

Kilian M Pohl, PhD"
Ender Konukoglu, PhD "
Andriy Fedorov, PhD"

ChangeTracker:  exploring small volumetric changes!
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•  Conventional anatomic imaging using CT or MRI are often used to evaluate 
tumor size and shape"

•  Most clinical trials that evaluate new chemotherapeutic drugs use changes in 
uni-dimensional or bi-dimensional measurements to assess response (e.g. 
RECIST)"

•  Slicer has several tools for applying RECIST methodologies"

ChangeTracker:  Conventional measures of tumor response!
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"
The distance measurement 

(mm) between fiducials will be 
updated in the Fiducial’s GUI."

3D Slicer’s Fiducials Module 
can be used to measure the 

longest diameter!
in a tumor cross section."

"
Two fiducials may be used to 

mark the tumor’s extent."

Quantifying tumor change:  Conventional measures of tumor response!
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3D Slicer’s  Measurements module, 
provides interactive measurement 

tools that operate in the 3D Viewer 
and the Slice Viewers. "

Interactive ruler can be used 
to measure the longest 
diameter and provides 
numerical annotations!

Quantifying tumor change:  Conventional measures of tumor response!
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3D Slicer’s  
LabelDiameterEstimation 

(extension) module will 
automatically compute the 

largest tumor diameter and 
orthogonal dimension."

"
This analysis requires an 

initial segmentation (VOI). "

Baseline: June 2006                   Follow-up: June 2007"

Quantifying tumor change:  Conventional measures of tumor response!
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•  However, more accurate and precise methods for 
understanding volume changes may be useful when:"

•  benign tumor change is being monitored, or"

•  where small changes may be clinically significant but 
difficult to assess with RECIST"

ChangeTracker:  rationale for new approaches!

•  ChangeTracker Module is a tool to measure 
volumetric change at the voxel level."
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"
Select File->Load Scene "

"

This raises the Load Scene Interface"
Select Slicer_data from favorites panel."

"
Select the ChangeTracker2010  directory"

"
And select the scene file: 

ChangetrackerTutorial2009.mrml !
 double click the file, or click Open!

ChangeTracker:  Load the training dataset!
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This course is built upon two scans of a patient with meningioma:"

MR Scan 1" MR Scan 2"

Please note: we have pre-adjusted the window and level settings 
for these volumes so that they are appropriate for display on most 
laptops. If display is not satisfactory on your machine or projector, the 
Volumes Module may be used to refine these settings. "

ChangeTracker:  about the data...!
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Meningioma!
•  Usually benign slow-growing tumors"
"
Baseline radiologist’s clinical impression:!
•  large falcine lesion is identified. "
•  measures 3.1 cm anteroposteriorly, 3.05 cm from      
side-to-side, 3.5 cm in height. "
•  enhances moderately on post gadolinium imaging. "
"
Follow-up radiologist’s clinical impression: !
•  left frontal lobe mass appears unchanged on all series. "
•  measures 3.3 x 3.2 cm in maximum dimension. "
•  enhances moderately on post gadolinium imaging. "
"
          How has the tumor changed?!

SCAN1!
Baseline: 

June 2006"

 SCAN2!
Follow-up: 
June 2007"

ChangeTracker:  Clinical context!
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"
Change Layout to “Four-up”:"
"
Using the Layout Menubutton,"
"

Select Four-up layout."

ChangeTracker:  exploring small volumetric changes!
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Using the Modules Menubutton,"
Select the ChangeTracker Module 
from the Wizards category."

ChangeTracker:  exploring small volumetric changes!
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A Workflow Wizard guides 
the user through a sequence 

of steps and has the following 
components: "

"
"

•  the Step Panel"
•  the User Panel"
•  the Navigation Panel"

ChangeTracker:  a note about the Workflow Wizard!

Step Panel--"
"
"
"

User Panel--"
"
"
"
"

Navigation Panel--"
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Select baseline & follow-up studies: "
 
Scan 1 = 2006-spgr "
Scan 2 = 2007-spgr  "

ChangeTracker:  First step: select scans!
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Move sliders in Slice 
Viewer Control panels to 
get a close-up view of 
tumor in Axial, Sagittal 
and Coronal slice 
viewers."
"
Zoom in (Right mouse 
down and push/pull)."
"
Pan (Middle mouse down 
and move)"

Press Next!

ChangeTracker:  inspect the tumor!
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A VOI Box Widget is positioned within the image volume in the 3D 
viewer, and the VOI’s intersection with each slice is shown in blue."

Center the VOI first:"
"
Right click in the tumor 
center to position the VOI 
displayed in blue in each Slice 
Viewer."

ChangeTracker:  Step 2. Define a volume of interest!
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View the VOI box widget and 
volume rendering of tumor in 

yellow in the 3D Viewer"Next, resize the VOI:!
"

Left click in any Slice Viewer 
to change the VOI extent"

ChangeTracker:  Step 2. Define a volume of interest!
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Note: VOI Widget range sliders are color-coded to match VOI 
box Widget handles in 3D Viewer"

Fine-tune the VOI using the VOI Widget range sliders                   
or by moving the VOI Widget handles in 3D view"

ChangeTracker:  Step 2. Define a volume of interest!
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Scroll through slices 
to ensure that tumor 

boundaries are included 
in the VOI."

"
Click Next"

ChangeTracker:  Step 2. Define a volume of interest!
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ChangeTracker:  Step 3. Segment the tumor!

You should see a volume called a 
Supersampled VOI from scan1  

selected in the background layer!
...and… a PresSegmented label map 

selected in the label layer."
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Slice Viewers show VOI 
with current 
segmentation overlay 
in light yellow  "

3D Viewer shows 
model of tumor!

Modify the 
segmentation by 

moving threshold 
range slider!

ChangeTracker:  Step 3. Segment the tumor!
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Scroll through the 
slices until the 
segmentation 
appears optimal."

ChangeTracker:  Step 3. Segment the tumor!

Press Next."
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ChangeTracker:  Final step: Select Metric for change detection!

Press the Slice option to 
view the volume 

rendered segmentation   
with the axial slice 

together."
"
"

If you need to reset the 
3D View, try using the 

Axis Navigator Widget."
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Metric Options:"
"

Detect change by 
analyzing intensity 

pattern (fast)!
"

Measure change by 
analyzing 

deformation map 
(slow)  !

Select fast and press 
Analyze!

ChangeTracker:  Final step: Select Metric!

Turn off “Slice” 
option in GUI panel 
is off.!
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Register Scan1 & Scan2 (baseline and follow-up) 
(preserve volume)

Konukoglu et al. ,“Monitoring Slowly Evolving Tumors”, ISBI, 2008 

Normalize intensities

Using segmentation and difference image, compute 
probability density function  of dormant tissue

Set threshold for voxel-wise analysis

ChangeTracker:  Algorithm details!
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Change in volume is shown 
overlaying the tumor image 
and in the 3D Viewer:  
magenta = growth 
green = shrinkage!

ChangeTracker:  Results: change in pathology!

Note: Analysis is 
displayed in the 
“Compare View” 
layout with linked 
control for the 
compare Viewers."
"
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“Compare View” layout 
displays:"
"
• Axial slice & 3D View"

• Five corresponding 
consecutive slices for the VOI in 
Scan1 (top row), and "

• in the Scan2 (bottom row).!

ChangeTracker:  Results: change in pathology!
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ChangeTracker:  Results: change in pathology!

Select visibility icon      to 
show axial slice in the 3D 
Viewer."
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Crosshairs in Compare View show corresponding voxels in 
Scan1 and Scan2 for voxel-wise comparison."

ChangeTracker:  Results: change in pathology!



-- CTSA at RSNA 2010 

Click on the colored bar at 
the top of any Slice Viewer to 

show or hide the controls."
"

This allows more display 
space for viewing the image 

data."

ChangeTracker:  Exploring small volumetric changes!
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Modify sensitivity of intensity 
pattern analysis"

sensitive"

moderate"

robust"

ChangeTracker:  Exploring small volumetric changes!

(You may need to twiddle the 3D viewer to see it update)"
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Tested on Axial 3D SPGR T1 post Gadolinium scans  (Voxel dimension: 0.94mm x 
0.94mm x 1.20mm, FOV: 240mm, Matrix: 256 x 256)."
"
Tumor boundary should be clear.!
"
Only for contrast enhanced images.!
"
Need homogenous enhancement across timepoints.!
"
Not tested for tumors with changing necrosis."
"
Correspondence between Intensity-based and deformation mapping-based 
analyses should be checked. "

ChangeTracker:  Exploring small volumetric changes!
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This tutorial demonstrated:"
"
•  a method to quantify small volumetric changes in pathology."
•  visualization of these changes in the anatomical context"
•  use of Slicer’s “Compare Viewer” to simultaneously explore 
baseline and followup studies."
"

Next, we will demonstrate combined visualization of 
PET/CT studies and SUV computation."
"

ChangeTracker:  exploring small volumetric changes!
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Clear the scene and its data.!

"
Close the previous scene."
"
Select File->Close Scene!

"
This removes any datasets 

previously  loaded into Slicer."
 "
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Part III:  PET/CT Analysis 
using 3D Slicer!

Jeffrey Yap PhD"
Ron Kikinis MD"

Wendy Plesniak PhD"

PET/CT Visualization and Analysis!



"
Select File->Load Scene "

"
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This raises the Load Scene Interface"
 select the file called "

  PETCTFusion-Tutorial-Scene.mrml!
"

 Double click the file, or click Open!

PET/CT Visualization and Analysis:  Load the new scene!
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Non small cell lung cancer patient!
"
"
Two PET studies: baseline acquired before treatment, and follow-up 
acquired 1 month after chemotherapy"
"
"
Two non-diagnostic CT images are acquired without the use of contrast"
"
"
FDG-PET scans acquired 60 minutes after intravenous injection of 
approximately 20 mCi of 18FDG "
"
Two VOIs have been created using Slicer’s Editor Module."
"

PET/CT Visualization and Analysis:  About the data!
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Using the Modules 
Menubutton: 
Expose the menu 
and select the 
module called 
PETCTFusion under 
the Quantification 
category.

PET/CT Visualization and Analysis:  Open the PETCTFusion Module
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In the Data Fusion panel, 
select:"
"
CT volume:   CT1!
!
PET volume:   PET1!
!
Tumor Mask: PET1-label!

When the PET volume is selected, a “wait message” will be 
displayed while parameters are read from DICOM header."

Note: Module requires DICOM format data"

PET/CT Visualization and Analysis:  Select baseline study!
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Note: this stacks the PET, CT and 
VOI in three layers:!

!
Background = CT1!

Foreground = PET1!
Overlay (Label) = PET1-label!

"
where they can be blended into a 

single visualization"

PET/CT Visualization and Analysis:  Information displayed in “Layers”!
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In the Display Panel, choose a 
colorization option for the PET 

volume from among"
Grey, Heat, or Spectrum. "

"
Adjust the window and level 

for CT1 and PET1 volumes."
"

Adjust the Slices Fade Scale to 
jointly display the datasets in 

the foreground and background 
layers."

PET/CT Visualization and Analysis:  Adjust display of the baseline study!
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Explore: !
in the Slice Viewers, scroll 
through the slices to 
locate the green Tumor 
label and the yellow Liver 
label."
"
Note: (the yellow label is 
used only to demonstrate 
multiple-VOI functionality)."

PET/CT Visualization and Analysis:  Explore the visualization!
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Shortcut: To view the same 
voxel in all Slice Viewers:"

"
Type –740 and hit enter in 

the Axial Slice Viewer’s Slice 
Number Entry"

"
 Then, hold down SHIFT, left 

click and drag inside the 
green VOI in the Axial slice. "

"
This displays the same(mm) 
position within the reference 
frame of all image volumes."

PET/CT Visualization and Analysis:  View tumor in all slice viewers!
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SUVmax and 
SUVmean for each 

VOI (represented 
by a different color 

in the label map) 
will  be displayed in 

the table."

In the Quantitative 
Measures panel, 

click the Compute/
Refresh button."

PET/CT Visualization and Analysis:  Compute SUV for all VOIs in baseline!
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Note these 
measurements for 
the tumor VOI, as 

weʼll compare those 
from the follow-up 

study to them."
"

SUVmax(bw) = 8.02 "
SUVmean(bw) = 3.64"

PET/CT Visualization and Analysis:  Compute SUV for all VOIs in baseline!
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Look for response to 
treatment in the follow-up 
study:"
!
In the Data Fusion panel, 
set:!
CT volume = CT2, "
PET volume = PET2 and 
Tumor Mask = PET2-label."

This dataset contains two 
VOIs that correspond to the 
segmentations the baseline 
study."

PET/CT Visualization and Analysis:  Compute SUVbw for follow-up study!
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Adjust the display for the 
follow-up study."

"
You may want to adjust 
the Slices Fade Slider 
and manipulate the 3D 

View to refresh them."

PET/CT Visualization and Analysis:  Modify display of the follow-up!
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In the “Quantitative Measures” Panel:"
"
select Compute/Refresh to compute 
SUVbw for the green Tumor volume (and 
yellow liver volume)."

PET/CT Visualization and Analysis:  Compute SUVbw for follow-up!
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Pre-Treatment Max SUVbw ="
"

Post-Treatment Max SUVbw ="

8.0 g/ml"
"

9.4 g/ml"
"

+16.61%  (SD)!

PET/CT Visualization and Analysis:  Assess response wrt this VOI!
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Still validating this module against performance of commercial systems. "
"
Appropriate only for DICOM PET studies only"
"
Not yet compatible with Philips datasets"

PET/CT Visualization and Analysis:  Appropriate Use!
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This workshop has demonstrated:!
"
•  Basic scene loading and visualization using 3D Slicer"

•  Use of Slicer’s ChangeTracker module to assess small 
changes in tumor size"

•  Workflow to make quantitative measurements of SUV (body 
weight) in Slicer’s PETCTFusion module"

Workshop Summary!
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Thank you for your attendance!!
"
Tutorial Slides:"
http://www.na-mic.org/Wiki/index.php/File:Combined-RSNA2010-CTSA.pptx"
"
Tutorial Data:"
http://wiki.na-mic.org/Wiki/images/5/51/Slicer3MinuteDataset.zip"
http://wiki.na-mic.org/Wiki/images/f/f8/RSNA-ChangeTracker-Tutorial-Data.zip"
http://wiki.na-mic.org/Wiki/images/7/73/PETCTFusion-Tutorial-Data.zip"
"
Tutorial Software:"
www.slicer.org/Downloads "
"
More Information:"
http://www.slicer.org"

Thank you and more information!
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